Disconnect regular during battle

Almost every time a battle exceeds a few minutes I tend to get disconnected, I mentioned in game and was told it's client side issues and told to restart, but this happens when I've just logged in and started my first battle.
Granted I've not got a new device, it's a Samsung s5, are there any other things I can do apart from turn graphics to low and shadows off? Because it hasn't helped at all.
Also, is there a way to prevent AI taking over when I disconnect? No matter how much of an upper hand I have they always seem to find a way to fall on the sword by the time I can log back on, they literally look for death as quick as they can knowing I'm not watching, with the frequency of the dcd( nearly every battle) it's made battles almost impossible, I haven't been able to level properly for days, I hoped the recent patch would solve it but seems to be the same.

When you say disconnect, do you mean you're kicked to the login screen, or the game closes entirely?
Are you playing on wifi or cell phone connection?
When it happens, are you able to re-connect immediately, or use any other internet services?

Ozymandias
When you say disconnect, do you mean you're kicked to the login screen, or the game closes entirely?
Are you playing on wifi or cell phone connection?
When it happens, are you able to re-connect immediately, or use any other internet services?


Yes kicked to the login screen with unable to find connection to the server message, on wifi at home. Yes other things work fine while this is happening, I can normally get back in within 30 seconds or so, if I try to connect instantly the same unable to connect message normally shows but not always. Could the s5 be the problem? Or internet provider? There's a few people who seem to be having dcd issues though so I thought I'd mention it just in case it's something that could be fixed.

Go to Settings -> Test & Debug - > "Debug Info On"
You will see green Ping / FPS information. Note the "Ping" value before/after a disconnect.
My guess is that the device is having a brief loss of wifi signal that interrupts the connection, but without having access to the device it's hard to know.
I'd be interested in knowing if other devices on the same network have similar behavior.

The Internet provider is Sky broadband so it's not the most reliable, although never had issues with tib in the past, at least not like this. Just had a couple of battles and didn't seem to have an issue, I'll keep an eye to see if it's worse at any particular time of day and check the ping when I get sent to login and report back.

Mine does this as well and guaranteed every time in the 30 secs it takes to log back on the ai manages to put you in a poor position if not lose the battle. Is there any way you can write in a delay of say 60 secs before the ai kicks in if the actual use ai button isn't clicked. then we stand a chance of getting logged back in before tHe ai loses the fight
.

i have the same problem.
other internet using apps seem to be fine. dont see any exceptional spikes.
maybe its related to the the following: as soon as a phone call comes in or popup from another app is accepted dire will disconnect even if you refuse it or bin it. then itvwill take a few login tries before you can log in. often ai will have screwed up. larger delay in ai to take over would also greatly help here.

This happens on my Android tablet as well, occasionally getting the "connection lost : cannot connect to server" type message, yet the tablet will access the internet just fine via browsers or other apps. I assumed it was my wifi playing up and usually I cannot reconnect immediately so I've always hopped onto my PC which connects and has no regular disconnect issues.

To help me fix the issue:
1) Note the exact time whenever this happens. I can check server logs to see what it thinks happened.
2) Watch your PING and try to note what it was before / after a disconnect.
3) Note other events, such as an incoming text message overlay. Maybe it disconnects a minute or two after?
4) Has anyone found a way to reliably reproduce it? Perhaps with a specific action, or sequence of events?

incomming message overlays will cause disconnect on my phone if i take any action on the popup window ( block or dismiss i think they are called). same, with accepting any call , switching to other app etc. internet will still be, available for other apps but it will take, about half a minute before i can logon again. in the mean time its cannot connect to server all the time.
this is, 100% reproducable.
ps if i just wait for the overlay to disapear it wont disconnnect.